es02.stablehost.com: General Spain Energy Outage

Incident Report for StableHost

Resolved

This incident has been resolved.
Posted Apr 29, 2025 - 09:48 CST

Update

We are continuing to work on a fix for this issue.
Posted Apr 28, 2025 - 10:20 CST

Identified

Spain and Portugal were hit by a widespread power outage. Spanish electricity transmission operator Red Eléctrica said the outage, the cause of which was not immediately known, could last several hours. Red Electrica said it was working with regional energy companies to restore power. Further updates later in the day.
Posted Apr 28, 2025 - 09:43 CST
This incident affected: Servers (Madrid, ES).