St. Louis Emergency Maintenance

Incident Report for StableHost

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 16:10 CST

Identified

There was an hardware replacement on the Data Center that may impact the performance of some of the servers at this location. The hardware was directly related to the storage units. This might me solved in 2-3 hours.
Posted Oct 29, 2025 - 14:52 CST
This incident affected: Servers (St. Loius, US).